summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/completer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/completer/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/completer/CMakeLists.txt42
1 files changed, 24 insertions, 18 deletions
diff --git a/examples/widgets/tools/completer/CMakeLists.txt b/examples/widgets/tools/completer/CMakeLists.txt
index b39b4f262d..9db2d089d9 100644
--- a/examples/widgets/tools/completer/CMakeLists.txt
+++ b/examples/widgets/tools/completer/CMakeLists.txt
@@ -1,23 +1,29 @@
# Generated from completer.pro.
-#####################################################################
-## completer Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(completer LANGUAGES CXX)
-add_qt_executable(completer
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/completer"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/tools/completer"
- SOURCES
- fsmodel.cpp fsmodel.h
- main.cpp
- mainwindow.cpp mainwindow.h
- LIBRARIES
- Qt::Widgets
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-# Resources:
-add_qt_resource(completer "completer" PREFIX "/" FILES
- resources/countries.txt
- resources/wordlist.txt)
+set(INSTALL_EXAMPLEDIR "examples")
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(completer WIN32 MACOSX_BUNDLE
+ completer.qrc
+ fsmodel.cpp fsmodel.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+)
+target_link_libraries(completer PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS completer
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+)