summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt b/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
index 728e6d4856..a362604018 100644
--- a/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
+++ b/examples/widgets/tools/echoplugin/echowindow/CMakeLists.txt
@@ -18,7 +18,11 @@ target_link_libraries(echopluginwindow PRIVATE
Qt6::Widgets
)
-if(NOT QT6_IS_SHARED_LIBS_BUILD)
+if(QT6_IS_SHARED_LIBS_BUILD)
+ # Build the shared plugin too when building this example target.
+ add_dependencies(echopluginwindow echoplugin)
+else()
+ # Link the echoplugin if Qt is built statically.
target_link_libraries(echopluginwindow PRIVATE
echoplugin
)