summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tools/echoplugin/plugin/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/echoplugin/plugin/CMakeLists.txt29
1 files changed, 4 insertions, 25 deletions
diff --git a/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt b/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
index 7ce196c4e2..fb727aa1d7 100644
--- a/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
+++ b/examples/widgets/tools/echoplugin/plugin/CMakeLists.txt
@@ -1,31 +1,11 @@
-# Generated from plugin.pro.
-
-cmake_minimum_required(VERSION 3.16)
-project(echoplugin LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/tools/echoplugin/plugins")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-
-qt_add_plugin(echoplugin)
+qt_add_plugin(echoplugin
+ CLASS_NAME EchoPlugin
+)
target_sources(echoplugin PRIVATE
echoplugin.cpp echoplugin.h
)
set_target_properties(echoplugin PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
+ LIBRARY_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/echowindow"
)
target_include_directories(echoplugin PUBLIC
../echowindow
@@ -39,6 +19,5 @@ target_link_libraries(echoplugin PUBLIC
install(TARGETS echoplugin
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)