summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tutorials/notepad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/tutorials/notepad/CMakeLists.txt')
-rw-r--r--examples/widgets/tutorials/notepad/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/examples/widgets/tutorials/notepad/CMakeLists.txt b/examples/widgets/tutorials/notepad/CMakeLists.txt
index 3c1fea3e6b..0ea8142c15 100644
--- a/examples/widgets/tutorials/notepad/CMakeLists.txt
+++ b/examples/widgets/tutorials/notepad/CMakeLists.txt
@@ -15,10 +15,10 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/tutorials/notepad")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS PrintSupport) # special case: add
+find_package(Qt6
+ REQUIRED COMPONENTS Core Gui Widgets
+ OPTIONAL_COMPONENTS PrintSupport
+)
qt_add_executable(notepad
main.cpp