summaryrefslogtreecommitdiffstats
path: root/examples/widgets/widgets/groupbox/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/widgets/widgets/groupbox/CMakeLists.txt')
-rw-r--r--examples/widgets/widgets/groupbox/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/examples/widgets/widgets/groupbox/CMakeLists.txt b/examples/widgets/widgets/groupbox/CMakeLists.txt
deleted file mode 100644
index ab2469eaad..0000000000
--- a/examples/widgets/widgets/groupbox/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(groupbox LANGUAGES CXX)
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-
-qt_standard_project_setup()
-
-qt_add_executable(groupbox
- main.cpp
- window.cpp window.h
-)
-
-set_target_properties(groupbox PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(groupbox PRIVATE
- Qt6::Core
- Qt6::Gui
- Qt6::Widgets
-)
-
-install(TARGETS groupbox
- BUNDLE DESTINATION .
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-)
-
-qt_generate_deploy_app_script(
- TARGET groupbox
- OUTPUT_SCRIPT deploy_script
- NO_UNSUPPORTED_PLATFORM_ERROR
-)
-install(SCRIPT ${deploy_script})