summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/CMakeLists.txt')
-rw-r--r--src/3rdparty/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/3rdparty/CMakeLists.txt b/src/3rdparty/CMakeLists.txt
index a597b47b52..f14da0e3c1 100644
--- a/src/3rdparty/CMakeLists.txt
+++ b/src/3rdparty/CMakeLists.txt
@@ -1,6 +1,3 @@
-# special case skip regeneration
-# The file is maintained manually
-
if(QT_FEATURE_gui AND QT_FEATURE_png AND NOT QT_FEATURE_system_png)
add_subdirectory(libpng)
endif()
@@ -11,6 +8,8 @@ if(QT_FEATURE_gui AND QT_FEATURE_jpeg AND NOT QT_FEATURE_system_jpeg)
endif()
qt_install_3rdparty_library_wrap_config_extra_file(BundledLibjpeg)
+# Needed for freetype, because it links against WrapPNG
+qt_find_package(WrapPNG PROVIDED_TARGETS WrapPNG::WrapPNG)
if(QT_FEATURE_gui AND QT_FEATURE_freetype AND NOT QT_FEATURE_system_freetype)
add_subdirectory(freetype)
endif()