summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/gradle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/gradle/CMakeLists.txt')
-rw-r--r--src/3rdparty/gradle/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/3rdparty/gradle/CMakeLists.txt b/src/3rdparty/gradle/CMakeLists.txt
index e9060a669f..3013eca1f9 100644
--- a/src/3rdparty/gradle/CMakeLists.txt
+++ b/src/3rdparty/gradle/CMakeLists.txt
@@ -42,3 +42,11 @@ qt_copy_or_install(
DESTINATION
"${destination}"
)
+
+if(NOT QT_WILL_INSTALL)
+ qt_internal_copy_at_build_time(TARGET Qt${QtBase_VERSION_MAJOR}GradleScripts
+ FILES ${gradle_programs} ${gradle_files}
+ DIRECTORIES ${gradle_wrapper}
+ DESTINATION ${destination}
+ )
+endif()