summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/harfbuzz/tests/linebreaking/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/harfbuzz/tests/linebreaking/Makefile.am')
-rw-r--r--src/3rdparty/harfbuzz/tests/linebreaking/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/3rdparty/harfbuzz/tests/linebreaking/Makefile.am b/src/3rdparty/harfbuzz/tests/linebreaking/Makefile.am
new file mode 100644
index 0000000000..b710896d6f
--- /dev/null
+++ b/src/3rdparty/harfbuzz/tests/linebreaking/Makefile.am
@@ -0,0 +1,12 @@
+
+check_PROGRAMS = linebreaking
+
+linebreaking_SOURCES = main.cpp harfbuzz-qt.cpp
+linebreaking_LDADD = $(QT_GUI_LIBS) $(QT_QTEST_LIBS) ../../src/libharfbuzz-1.la
+
+main.o: main.moc
+
+main.moc: $(srcdir)/main.cpp
+ $(QT_MOC) -o main.moc $(srcdir)/main.cpp
+
+INCLUDES = -I$(top_srcdir)/src $(FREETYPE_CFLAGS) $(QT_GUI_CFLAGS) $(QT_QTEST_CFLAGS)