summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/libpng/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/libpng/CMakeLists.txt')
-rw-r--r--src/3rdparty/libpng/CMakeLists.txt29
1 files changed, 16 insertions, 13 deletions
diff --git a/src/3rdparty/libpng/CMakeLists.txt b/src/3rdparty/libpng/CMakeLists.txt
index 24fca5d925..8f59719f28 100644
--- a/src/3rdparty/libpng/CMakeLists.txt
+++ b/src/3rdparty/libpng/CMakeLists.txt
@@ -1,12 +1,11 @@
-# Generated from libpng.pro.
-
#####################################################################
## BundledLibpng Generic Library:
#####################################################################
-qt_add_3rdparty_library(BundledLibpng
+qt_internal_add_3rdparty_library(BundledLibpng
QMAKE_LIB_NAME libpng
STATIC
+ SKIP_AUTOMOC
INSTALL
SOURCES
png.c
@@ -27,29 +26,33 @@ qt_add_3rdparty_library(BundledLibpng
DEFINES
PNG_ARM_NEON_OPT=0
PNG_POWERPC_VSX_OPT=0
+ PNG_IMPEXP=
+ _CRT_SECURE_NO_DEPRECATE
PUBLIC_INCLUDE_DIRECTORIES
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
)
-qt_disable_warnings(BundledLibpng)
-qt_set_symbol_visibility_hidden(BundledLibpng)
-#### Keys ignored in scope 1:.:.:libpng.pro:<TRUE>:
-# TR_EXCLUDE = "$$PWD/*"
+qt_internal_add_3rdparty_header_module(PngPrivate
+ EXTERNAL_HEADERS
+ png.h
+ pngconf.h
+ pnglibconf.h
+)
-## Scopes:
-#####################################################################
+qt_disable_warnings(BundledLibpng)
+qt_set_symbol_visibility_hidden(BundledLibpng)
-qt_extend_target(BundledLibpng CONDITION QT_FEATURE_system_zlib
+qt_internal_extend_target(BundledLibpng CONDITION QT_FEATURE_system_zlib
LIBRARIES
- ZLIB::ZLIB
+ WrapZLIB::WrapZLIB
)
-qt_extend_target(BundledLibpng CONDITION NOT QT_FEATURE_system_zlib
+qt_internal_extend_target(BundledLibpng CONDITION NOT QT_FEATURE_system_zlib
INCLUDE_DIRECTORIES
../zlib/src
)
-qt_extend_target(BundledLibpng CONDITION NOT QT_FEATURE_system_zlib AND NOT no_core_dep
+qt_internal_extend_target(BundledLibpng CONDITION NOT QT_FEATURE_system_zlib AND NOT no_core_dep
LIBRARIES
Qt::Core
)