summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/pcre2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/3rdparty/pcre2/CMakeLists.txt')
-rw-r--r--src/3rdparty/pcre2/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/3rdparty/pcre2/CMakeLists.txt b/src/3rdparty/pcre2/CMakeLists.txt
index a688cf608a..ec549515d2 100644
--- a/src/3rdparty/pcre2/CMakeLists.txt
+++ b/src/3rdparty/pcre2/CMakeLists.txt
@@ -11,6 +11,7 @@ qt_internal_add_3rdparty_library(BundledPcre2
src/pcre2.h
src/pcre2_auto_possess.c
src/pcre2_chartables.c
+ src/pcre2_chkdint.c
src/pcre2_compile.c
src/pcre2_config.c
src/pcre2_context.c
@@ -44,6 +45,8 @@ qt_internal_add_3rdparty_library(BundledPcre2
PCRE2_CODE_UNIT_WIDTH=16
PUBLIC_INCLUDE_DIRECTORIES
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/src>
+ CPE_VENDOR "pcre"
+ CPE_PRODUCT "pcre2"
)
qt_disable_warnings(BundledPcre2)
qt_set_symbol_visibility_hidden(BundledPcre2)