summaryrefslogtreecommitdiffstats
path: root/src/android/templates/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/android/templates/CMakeLists.txt')
-rw-r--r--src/android/templates/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/android/templates/CMakeLists.txt b/src/android/templates/CMakeLists.txt
index 3eba4611e8..94f3243c22 100644
--- a/src/android/templates/CMakeLists.txt
+++ b/src/android/templates/CMakeLists.txt
@@ -3,8 +3,6 @@
# Android template files
-# special case skip regeneration
-# special case begin
set(template_files
"${CMAKE_CURRENT_SOURCE_DIR}/AndroidManifest.xml"
"${CMAKE_CURRENT_SOURCE_DIR}/build.gradle")
@@ -16,9 +14,10 @@ add_custom_target(Qt${QtBase_VERSION_MAJOR}AndroidTemplates
SOURCES
${template_files}
"${CMAKE_CURRENT_SOURCE_DIR}/res/values/libs.xml"
+ "${CMAKE_CURRENT_SOURCE_DIR}/res/xml/qtprovider_paths.xml"
)
-qt_path_join(destination ${QT_INSTALL_DIR} "src/android/templates")
+qt_path_join(destination ${QT_INSTALL_DIR} ${INSTALL_DATADIR} "src/android/templates")
qt_copy_or_install(FILES ${template_files}
DESTINATION "${destination}")
@@ -33,5 +32,3 @@ if(NOT QT_WILL_INSTALL)
DESTINATION ${destination}
)
endif()
-
-# special case end