summaryrefslogtreecommitdiffstats
path: root/src/concurrent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/concurrent/CMakeLists.txt')
-rw-r--r--src/concurrent/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/concurrent/CMakeLists.txt b/src/concurrent/CMakeLists.txt
index 73aa12dea0..504f854534 100644
--- a/src/concurrent/CMakeLists.txt
+++ b/src/concurrent/CMakeLists.txt
@@ -25,8 +25,10 @@ qt_internal_add_module(Concurrent
qtconcurrenttask.h
qtconcurrentthreadengine.cpp qtconcurrentthreadengine.h
DEFINES
+ QT_NO_CONTEXTLESS_CONNECT
QT_NO_FOREACH
QT_NO_USING_NAMESPACE
+ QT_USE_NODISCARD_FILE_OPEN
LIBRARIES
Qt::CorePrivate
PUBLIC_LIBRARIES