summaryrefslogtreecommitdiffstats
path: root/src/dbus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/dbus/CMakeLists.txt')
-rw-r--r--src/dbus/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/src/dbus/CMakeLists.txt b/src/dbus/CMakeLists.txt
index 09fcdfd255..4768460e05 100644
--- a/src/dbus/CMakeLists.txt
+++ b/src/dbus/CMakeLists.txt
@@ -60,18 +60,10 @@ set_source_files_properties(qdbusmarshaller.cpp
extend_target(DBus CONDITION QT_FEATURE_dbus_linked
DEFINES
QT_LINKED_LIBDBUS
- PUBLIC_LIBRARIES # special case
+ LIBRARIES
dbus-1
)
-# begin special case:
-extend_target(DBus CONDITION NOT QT_FEATURE_dbus_linked
- PUBLIC_LIBRARIES
- dbus-1_nolink
-)
-# end special case:
-
-
extend_target(DBus CONDITION WIN32
LIBRARIES
advapi32