summaryrefslogtreecommitdiffstats
path: root/src/entrypoint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/entrypoint/CMakeLists.txt')
-rw-r--r--src/entrypoint/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/entrypoint/CMakeLists.txt b/src/entrypoint/CMakeLists.txt
index 845ce419ea..ba8342e41a 100644
--- a/src/entrypoint/CMakeLists.txt
+++ b/src/entrypoint/CMakeLists.txt
@@ -1,9 +1,7 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# special case begin
-# special case skip regeneration
-if (NOT WIN32 AND NOT CMAKE_SYSTEM_NAME STREQUAL "iOS")
+if (NOT (WIN32 OR UIKIT))
return()
endif()
@@ -113,7 +111,7 @@ if(WIN32)
qt_internal_add_sync_header_dependencies(EntryPointImplementation Core)
endif()
-if(CMAKE_SYSTEM_NAME STREQUAL "iOS")
+if(UIKIT)
set_target_properties(EntryPointPrivate PROPERTIES
INTERFACE_LINK_OPTIONS "-Wl,-e,_qt_main_wrapper"
)
@@ -150,5 +148,3 @@ qt_internal_export_additional_targets_file(
TARGETS ${export_targets}
EXPORT_NAME_PREFIX ${export_name_prefix}
CONFIG_INSTALL_DIR "${config_install_dir}")
-
-# special case end