summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index e503eb6a88..a7c0006bb9 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -567,10 +567,17 @@ qt_internal_extend_target(Gui CONDITION ((QT_FEATURE_png) AND (WIN32 AND MINGW))
)
if(NOT ANDROID)
- qt_internal_add_simd_part(Gui SIMD sse2
- SOURCES
- painting/qdrawhelper_sse2.cpp
- )
+ if(TEST_architecture_arch STREQUAL x86_64)
+ qt_internal_extend_target(Gui
+ SOURCES
+ painting/qdrawhelper_sse2.cpp
+ )
+ else()
+ qt_internal_add_simd_part(Gui SIMD sse2
+ SOURCES
+ painting/qdrawhelper_sse2.cpp
+ )
+ endif()
qt_internal_add_simd_part(Gui SIMD ssse3
SOURCES