summaryrefslogtreecommitdiffstats
path: root/src/opengl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/opengl/CMakeLists.txt')
-rw-r--r--src/opengl/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/opengl/CMakeLists.txt b/src/opengl/CMakeLists.txt
index 9cba766d10..52af12d683 100644
--- a/src/opengl/CMakeLists.txt
+++ b/src/opengl/CMakeLists.txt
@@ -7,6 +7,7 @@
qt_internal_add_module(OpenGL
SOURCES
+ compat/removed_api.cpp
qopengl2pexvertexarray.cpp qopengl2pexvertexarray_p.h
qopenglbuffer.cpp qopenglbuffer.h
qopenglcustomshaderstage.cpp qopenglcustomshaderstage_p.h
@@ -35,9 +36,13 @@ qt_internal_add_module(OpenGL
qtopenglglobal.h
NO_UNITY_BUILD_SOURCES
qopengltextureblitter.cpp # qDebug()<< ambiguities
+ NO_PCH_SOURCES
+ compat/removed_api.cpp
DEFINES
+ QT_NO_CONTEXTLESS_CONNECT
QT_NO_FOREACH
QT_NO_USING_NAMESPACE
+ QT_USE_NODISCARD_FILE_OPEN
LIBRARIES
Qt::CorePrivate
Qt::GuiPrivate
@@ -47,7 +52,6 @@ qt_internal_add_module(OpenGL
PRIVATE_MODULE_INTERFACE
Qt::CorePrivate
Qt::GuiPrivate
- GENERATE_CPP_EXPORTS
)
## Scopes: