summaryrefslogtreecommitdiffstats
path: root/src/opengl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/opengl/CMakeLists.txt')
-rw-r--r--src/opengl/CMakeLists.txt45
1 files changed, 31 insertions, 14 deletions
diff --git a/src/opengl/CMakeLists.txt b/src/opengl/CMakeLists.txt
index 781301dc0f..825e4cb71b 100644
--- a/src/opengl/CMakeLists.txt
+++ b/src/opengl/CMakeLists.txt
@@ -1,10 +1,11 @@
-# Generated from opengl.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## OpenGL Module:
#####################################################################
-qt_add_module(OpenGL
+qt_internal_add_module(OpenGL
SOURCES
qopengl2pexvertexarray.cpp qopengl2pexvertexarray_p.h
qopenglbuffer.cpp qopenglbuffer.h
@@ -25,16 +26,20 @@ qt_add_module(OpenGL
qopengltextureglyphcache.cpp qopengltextureglyphcache_p.h
qopengltexturehelper.cpp qopengltexturehelper_p.h
qopengltextureuploader.cpp qopengltextureuploader_p.h
+ qopengltimerquery.h
qopenglversionfunctions.cpp qopenglversionfunctions.h qopenglversionfunctions_p.h
qopenglversionfunctionsfactory.cpp qopenglversionfunctionsfactory.h
qopenglversionprofile.cpp qopenglversionprofile.h
- qopenglvertexarrayobject.cpp qopenglvertexarrayobject.h
+ qopenglvertexarrayobject.cpp qopenglvertexarrayobject.h qopenglvertexarrayobject_p.h
qopenglwindow.cpp qopenglwindow.h
- qplatformbackingstoreopenglsupport.cpp qplatformbackingstoreopenglsupport.h
qtopenglglobal.h
+ NO_UNITY_BUILD_SOURCES
+ qopengltextureblitter.cpp # qDebug()<< ambiguities
DEFINES
+ QT_NO_CONTEXTLESS_CONNECT
QT_NO_FOREACH
QT_NO_USING_NAMESPACE
+ QT_USE_NODISCARD_FILE_OPEN
LIBRARIES
Qt::CorePrivate
Qt::GuiPrivate
@@ -44,17 +49,23 @@ qt_add_module(OpenGL
PRIVATE_MODULE_INTERFACE
Qt::CorePrivate
Qt::GuiPrivate
+ GENERATE_CPP_EXPORTS
)
## Scopes:
#####################################################################
-qt_extend_target(OpenGL CONDITION QT_FEATURE_opengles2
+qt_internal_extend_target(OpenGL CONDITION APPLE
+ NO_UNITY_BUILD_SOURCES
+ qopenglversionfunctionsfactory.cpp
+)
+
+qt_internal_extend_target(OpenGL CONDITION QT_FEATURE_opengles2
SOURCES
qopenglfunctions_es2.cpp qopenglfunctions_es2.h
)
-qt_extend_target(OpenGL CONDITION NOT QT_FEATURE_opengles2
+qt_internal_extend_target(OpenGL CONDITION NOT QT_FEATURE_opengles2
SOURCES
qopenglfunctions_1_0.cpp qopenglfunctions_1_0.h
qopenglfunctions_1_1.cpp qopenglfunctions_1_1.h
@@ -83,24 +94,30 @@ qt_extend_target(OpenGL CONDITION NOT QT_FEATURE_opengles2
qopenglfunctions_4_5_compatibility.cpp qopenglfunctions_4_5_compatibility.h
qopenglfunctions_4_5_core.cpp qopenglfunctions_4_5_core.h
qopenglqueryhelper_p.h
- qopengltimerquery.cpp qopengltimerquery.h
+ qopengltimerquery.cpp
)
-qt_extend_target(OpenGL CONDITION QT_FEATURE_vulkan
+qt_internal_extend_target(OpenGL CONDITION QT_FEATURE_vulkan
SOURCES
qvkconvenience.cpp qvkconvenience_p.h
- PUBLIC_LIBRARIES
- Vulkan::Vulkan_nolink
)
+if(QT_FEATURE_vulkan)
+ qt_internal_add_target_include_dirs_and_optionally_propagate(
+ OpenGL WrapVulkanHeaders::WrapVulkanHeaders)
+endif()
-qt_extend_target(OpenGL CONDITION QT_FEATURE_egl
+qt_internal_extend_target(OpenGL CONDITION QT_FEATURE_egl
SOURCES
qopenglcompositor.cpp qopenglcompositor_p.h
qopenglcompositorbackingstore.cpp qopenglcompositorbackingstore_p.h
)
-qt_create_tracepoints(OpenGL qtopengl.tracepoints)
-qt_add_docs(OpenGL
+qt_internal_generate_tracepoints(OpenGL opengl
+ SOURCES
+ qopenglframebufferobject.cpp
+ qopenglpaintengine.cpp
+ qopengltexturecache.cpp
+)
+qt_internal_add_docs(OpenGL
doc/qtopengl.qdocconf
)
-