summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/platformsupport/CMakeLists.txt')
-rw-r--r--src/platformsupport/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/platformsupport/CMakeLists.txt b/src/platformsupport/CMakeLists.txt
index ece4eed2aa..cac0b21782 100644
--- a/src/platformsupport/CMakeLists.txt
+++ b/src/platformsupport/CMakeLists.txt
@@ -44,7 +44,7 @@ if(QT_FEATURE_opengl)
add_subdirectory(platformcompositor)
endif()
-if (QT_FEATURE_xlib AND QT_FEATURE_opengl AND (NOT QT_FEATURE_opengles2))
+if (QT_FEATURE_xlib AND QT_FEATURE_opengl AND TARGET OpenGL::GLX) # special case
add_subdirectory(glxconvenience)
endif()