summaryrefslogtreecommitdiffstats
path: root/src/plugins/generic/libinput/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/generic/libinput/CMakeLists.txt')
-rw-r--r--src/plugins/generic/libinput/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/src/plugins/generic/libinput/CMakeLists.txt b/src/plugins/generic/libinput/CMakeLists.txt
index d7c434391e..f92b3d5353 100644
--- a/src/plugins/generic/libinput/CMakeLists.txt
+++ b/src/plugins/generic/libinput/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from libinput.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## QLibInputPlugin Plugin:
@@ -6,17 +7,14 @@
qt_internal_add_plugin(QLibInputPlugin
OUTPUT_NAME qlibinputplugin
- TYPE generic
+ PLUGIN_TYPE generic
+ DEFAULT_IF FALSE
SOURCES
main.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
Qt::InputSupportPrivate
)
-
-#### Keys ignored in scope 1:.:.:libinput.pro:<TRUE>:
-# OTHER_FILES = "libinput.json"
-# PLUGIN_EXTENDS = "-"