summaryrefslogtreecommitdiffstats
path: root/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt')
-rw-r--r--src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt b/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt
new file mode 100644
index 0000000000..a939ab4405
--- /dev/null
+++ b/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_plugin(QSCNetworkReachabilityNetworkInformationPlugin
+ OUTPUT_NAME qscnetworkreachability
+ CLASS_NAME QSCNetworkReachabilityNetworkInformationBackendFactory
+ PLUGIN_TYPE networkinformation
+ DEFAULT_IF APPLE
+ SOURCES
+ qscnetworkreachabilitynetworkinformationbackend.mm
+ LIBRARIES
+ Qt::NetworkPrivate
+ ${FWSystemConfiguration}
+)