summaryrefslogtreecommitdiffstats
path: root/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt')
-rw-r--r--src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt b/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt
index 87ca1f0a6d..a939ab4405 100644
--- a/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt
+++ b/src/plugins/networkinformation/scnetworkreachability/CMakeLists.txt
@@ -1,11 +1,14 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
qt_internal_add_plugin(QSCNetworkReachabilityNetworkInformationPlugin
- OUTPUT_NAME scnetworkreachability
+ OUTPUT_NAME qscnetworkreachability
CLASS_NAME QSCNetworkReachabilityNetworkInformationBackendFactory
- TYPE networkinformation
+ PLUGIN_TYPE networkinformation
DEFAULT_IF APPLE
SOURCES
qscnetworkreachabilitynetworkinformationbackend.mm
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::NetworkPrivate
${FWSystemConfiguration}
)