summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/cocoa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/cocoa/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/cocoa/CMakeLists.txt90
1 files changed, 20 insertions, 70 deletions
diff --git a/src/plugins/platforms/cocoa/CMakeLists.txt b/src/plugins/platforms/cocoa/CMakeLists.txt
index 9e8b162aec..92e681d8fb 100644
--- a/src/plugins/platforms/cocoa/CMakeLists.txt
+++ b/src/plugins/platforms/cocoa/CMakeLists.txt
@@ -1,19 +1,16 @@
-# Generated from cocoa.pro.
-
-# special case:
-qt_find_package(Cups PROVIDED_TARGETS Cups::Cups)
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## QCocoaIntegrationPlugin Plugin:
#####################################################################
-qt_add_plugin(QCocoaIntegrationPlugin
+qt_internal_add_plugin(QCocoaIntegrationPlugin
OUTPUT_NAME qcocoa
- DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES cocoa # special case
- TYPE platforms
+ DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES cocoa
+ PLUGIN_TYPE platforms
SOURCES
main.mm
- messages.cpp messages.h
qcocoaapplication.h qcocoaapplication.mm
qcocoaapplicationdelegate.h qcocoaapplicationdelegate.mm
qcocoabackingstore.h qcocoabackingstore.mm
@@ -25,7 +22,6 @@ qt_add_plugin(QCocoaIntegrationPlugin
qcocoainputcontext.h qcocoainputcontext.mm
qcocoaintegration.h qcocoaintegration.mm
qcocoaintrospection.h qcocoaintrospection.mm
- qcocoakeymapper.h qcocoakeymapper.mm
qcocoamenu.h qcocoamenu.mm
qcocoamenubar.h qcocoamenubar.mm
qcocoamenuitem.h qcocoamenuitem.mm
@@ -45,7 +41,13 @@ qt_add_plugin(QCocoaIntegrationPlugin
qnsview.h qnsview.mm
qnswindow.h qnswindow.mm
qnswindowdelegate.h qnswindowdelegate.mm
- PUBLIC_LIBRARIES
+ qcocoacolordialoghelper.h qcocoacolordialoghelper.mm
+ qcocoafiledialoghelper.h qcocoafiledialoghelper.mm
+ qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
+ qcocoamessagedialog.h qcocoamessagedialog.mm
+ DEFINES
+ QT_NO_FOREACH
+ LIBRARIES
${FWAppKit}
${FWCarbon}
${FWCoreServices}
@@ -54,17 +56,15 @@ qt_add_plugin(QCocoaIntegrationPlugin
${FWIOSurface}
${FWMetal}
${FWQuartzCore}
- Cups::Cups
- Qt::ClipboardSupportPrivate
+ ${FWUniformTypeIdentifiers}
Qt::Core
Qt::CorePrivate
- Qt::FontDatabaseSupportPrivate
- Qt::GraphicsSupportPrivate
Qt::Gui
Qt::GuiPrivate
- Qt::ThemeSupportPrivate
)
+qt_disable_apple_app_extension_api_only(QCocoaIntegrationPlugin)
+
# Resources:
set(qcocoaresources_resource_files
"images/sizeallcursor.png"
@@ -72,83 +72,33 @@ set(qcocoaresources_resource_files
"images/waitcursor.png"
)
-qt_add_resource(QCocoaIntegrationPlugin "qcocoaresources"
+qt_internal_add_resource(QCocoaIntegrationPlugin "qcocoaresources"
PREFIX
"/qt-project.org/mac/cursors"
FILES
${qcocoaresources_resource_files}
)
-
-#### Keys ignored in scope 1:.:.:cocoa.pro:<TRUE>:
-# OTHER_FILES = "cocoa.json"
-
## Scopes:
#####################################################################
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_opengl
+qt_internal_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_opengl
SOURCES
qcocoaglcontext.h qcocoaglcontext.mm
)
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_vulkan
+qt_internal_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_vulkan
SOURCES
qcocoavulkaninstance.h qcocoavulkaninstance.mm
- PUBLIC_LIBRARIES
- Qt::VulkanSupportPrivate
)
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_accessibility
+qt_internal_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_accessibility
SOURCES
qcocoaaccessibility.h qcocoaaccessibility.mm
qcocoaaccessibilityelement.h qcocoaaccessibilityelement.mm
- PUBLIC_LIBRARIES
- Qt::AccessibilitySupportPrivate
)
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_sessionmanager
+qt_internal_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_sessionmanager
SOURCES
qcocoasessionmanager.cpp qcocoasessionmanager.h
)
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::PlatformCompositorSupportPrivate
- PUBLIC_LIBRARIES
- Qt::PlatformCompositorSupportPrivate
-)
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::Widgets
- SOURCES
- qpaintengine_mac.mm qpaintengine_mac_p.h
- PUBLIC_LIBRARIES
- Qt::WidgetsPrivate
-)
-
-#### Keys ignored in scope 8:.:.:cocoa.pro:TARGET Qt::Widgets:
-# QT_FOR_CONFIG = "widgets"
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
- SOURCES
- qcocoaprintdevice.h qcocoaprintdevice.mm
- qcocoaprintersupport.h qcocoaprintersupport.mm
- qprintengine_mac.mm qprintengine_mac_p.h
- PUBLIC_LIBRARIES
- Qt::PrintSupportPrivate
-)
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_colordialog AND TARGET Qt::Widgets
- SOURCES
- qcocoacolordialoghelper.h qcocoacolordialoghelper.mm
-)
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_filedialog AND TARGET Qt::Widgets
- SOURCES
- qcocoafiledialoghelper.h qcocoafiledialoghelper.mm
-)
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_fontdialog AND TARGET Qt::Widgets
- SOURCES
- qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
-)
-
-#### Keys ignored in scope 13:.:.:cocoa.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
-# PLUGIN_EXTENDS = "-"