summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/offscreen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platforms/offscreen/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/offscreen/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/plugins/platforms/offscreen/CMakeLists.txt b/src/plugins/platforms/offscreen/CMakeLists.txt
index 7387e083b6..5d9dd0083c 100644
--- a/src/plugins/platforms/offscreen/CMakeLists.txt
+++ b/src/plugins/platforms/offscreen/CMakeLists.txt
@@ -19,7 +19,6 @@ qt_internal_add_plugin(QOffscreenIntegrationPlugin
Qt::Core
Qt::CorePrivate
Qt::EventDispatcherSupportPrivate
- Qt::FontDatabaseSupportPrivate
Qt::Gui
Qt::GuiPrivate
)
@@ -30,6 +29,11 @@ qt_internal_add_plugin(QOffscreenIntegrationPlugin
## Scopes:
#####################################################################
+qt_extend_target(QOffscreenIntegrationPlugin CONDITION NOT APPLE
+ PUBLIC_LIBRARIES
+ Qt::FontDatabaseSupportPrivate
+)
+
qt_extend_target(QOffscreenIntegrationPlugin CONDITION QT_FEATURE_opengl AND QT_FEATURE_xlib AND NOT QT_FEATURE_opengles2
SOURCES
qoffscreenintegration_x11.cpp qoffscreenintegration_x11.h
@@ -37,5 +41,5 @@ qt_extend_target(QOffscreenIntegrationPlugin CONDITION QT_FEATURE_opengl AND QT_
Qt::GlxSupportPrivate
)
-#### Keys ignored in scope 3:.:.:offscreen.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+#### Keys ignored in scope 4:.:.:offscreen.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
# PLUGIN_EXTENDS = "-"