summaryrefslogtreecommitdiffstats
path: root/src/plugins/platformthemes/xdgdesktopportal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/platformthemes/xdgdesktopportal/CMakeLists.txt')
-rw-r--r--src/plugins/platformthemes/xdgdesktopportal/CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/src/plugins/platformthemes/xdgdesktopportal/CMakeLists.txt b/src/plugins/platformthemes/xdgdesktopportal/CMakeLists.txt
index a9062f695f..6228e83ec7 100644
--- a/src/plugins/platformthemes/xdgdesktopportal/CMakeLists.txt
+++ b/src/plugins/platformthemes/xdgdesktopportal/CMakeLists.txt
@@ -1,24 +1,22 @@
-# Generated from xdgdesktopportal.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## QXdgDesktopPortalThemePlugin Plugin:
#####################################################################
-qt_add_plugin(QXdgDesktopPortalThemePlugin
+qt_internal_add_plugin(QXdgDesktopPortalThemePlugin
OUTPUT_NAME qxdgdesktopportal
- TYPE platformthemes
+ PLUGIN_TYPE platformthemes
+ DEFAULT_IF FALSE
SOURCES
main.cpp
qxdgdesktopportalfiledialog.cpp qxdgdesktopportalfiledialog_p.h
qxdgdesktopportaltheme.cpp qxdgdesktopportaltheme.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
Qt::CorePrivate
Qt::DBus
Qt::Gui
Qt::GuiPrivate
- Qt::ThemeSupportPrivate
)
-
-#### Keys ignored in scope 1:.:.:xdgdesktopportal.pro:<TRUE>:
-# PLUGIN_EXTENDS = "-"