summaryrefslogtreecommitdiffstats
path: root/src/plugins/sqldrivers/odbc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/sqldrivers/odbc/CMakeLists.txt')
-rw-r--r--src/plugins/sqldrivers/odbc/CMakeLists.txt10
1 files changed, 3 insertions, 7 deletions
diff --git a/src/plugins/sqldrivers/odbc/CMakeLists.txt b/src/plugins/sqldrivers/odbc/CMakeLists.txt
index c4ebd5fc4b..7812aced2c 100644
--- a/src/plugins/sqldrivers/odbc/CMakeLists.txt
+++ b/src/plugins/sqldrivers/odbc/CMakeLists.txt
@@ -1,13 +1,11 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR GPL-3.0-only WITH Qt-GPL-exception-1.0
-
-# Generated from odbc.pro.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## QODBCDriverPlugin Plugin:
#####################################################################
-qt_find_package(ODBC) # special case
+qt_find_package(ODBC)
qt_internal_add_plugin(QODBCDriverPlugin
OUTPUT_NAME qsqlodbc
@@ -18,6 +16,7 @@ qt_internal_add_plugin(QODBCDriverPlugin
DEFINES
QT_NO_CAST_FROM_ASCII
QT_NO_CAST_TO_ASCII
+ QT_NO_CONTEXTLESS_CONNECT
LIBRARIES
ODBC::ODBC
Qt::Core
@@ -25,9 +24,6 @@ qt_internal_add_plugin(QODBCDriverPlugin
Qt::SqlPrivate
)
-#### Keys ignored in scope 1:.:.:odbc.pro:<TRUE>:
-# OTHER_FILES = "odbc.json"
-
## Scopes:
#####################################################################