summaryrefslogtreecommitdiffstats
path: root/src/plugins/tls/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/tls/CMakeLists.txt')
-rw-r--r--src/plugins/tls/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/plugins/tls/CMakeLists.txt b/src/plugins/tls/CMakeLists.txt
new file mode 100644
index 0000000000..91b9267123
--- /dev/null
+++ b/src/plugins/tls/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(QT_FEATURE_securetransport)
+ add_subdirectory(securetransport)
+endif()
+
+if (QT_FEATURE_openssl OR QT_FEATURE_openssl_linked)
+ add_subdirectory(openssl)
+endif()
+
+if (QT_FEATURE_schannel)
+ add_subdirectory(schannel)
+endif()
+
+add_subdirectory(certonly)