summaryrefslogtreecommitdiffstats
path: root/src/tools/qdbusxml2cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/qdbusxml2cpp/CMakeLists.txt')
-rw-r--r--src/tools/qdbusxml2cpp/CMakeLists.txt23
1 files changed, 2 insertions, 21 deletions
diff --git a/src/tools/qdbusxml2cpp/CMakeLists.txt b/src/tools/qdbusxml2cpp/CMakeLists.txt
index b79c8002e8..0da22ebfc6 100644
--- a/src/tools/qdbusxml2cpp/CMakeLists.txt
+++ b/src/tools/qdbusxml2cpp/CMakeLists.txt
@@ -1,16 +1,15 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from qdbusxml2cpp.pro.
-
#####################################################################
## qdbusxml2cpp Tool:
#####################################################################
qt_get_tool_target_name(target_name qdbusxml2cpp)
qt_internal_add_tool(${target_name}
+ TRY_RUN
TARGET_DESCRIPTION "Qt D-Bus XML to C++ Compiler"
- TOOLS_TARGET DBus # special case
+ TOOLS_TARGET DBus
SOURCES
qdbusxml2cpp.cpp
DEFINES
@@ -19,23 +18,5 @@ qt_internal_add_tool(${target_name}
LIBRARIES
Qt::CorePrivate
Qt::DBusPrivate
- # COMPILE_OPTIONS # special case
- # "$$QT_HOST_CFLAGS_DBUS"
- # QMAKE_TARGET_DESCRIPTION = "Qt D-Bus XML to C++ Compiler"
- # _LOADED = "qt_tool"
- # _OPTION = "host_build"
)
qt_internal_return_unless_building_tools()
-
-#### Keys ignored in scope 1:.:.:qdbusxml2cpp.pro:<TRUE>:
-# QMAKE_TARGET_DESCRIPTION = "Qt D-Bus XML to C++ Compiler"
-# _OPTION = "host_build"
-
-## Scopes:
-#####################################################################
-
-# special case begin
-# qt_internal_extend_target(qdbusxml2cpp CONDITION NOT force_bootstrap [...])
-# qt_internal_extend_target(qdbusxml2cpp CONDITION NOT QT_FEATURE_commandlineparser AND NOT force_bootstrap [...])
-# qt_internal_extend_target(qdbusxml2cpp CONDITION force_bootstrap [...])
-# special case end