summaryrefslogtreecommitdiffstats
path: root/src/winmain/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/winmain/CMakeLists.txt')
-rw-r--r--src/winmain/CMakeLists.txt27
1 files changed, 0 insertions, 27 deletions
diff --git a/src/winmain/CMakeLists.txt b/src/winmain/CMakeLists.txt
deleted file mode 100644
index 73a1149717..0000000000
--- a/src/winmain/CMakeLists.txt
+++ /dev/null
@@ -1,27 +0,0 @@
-# special case begin
-# special case skip regeneration
-if (NOT WIN32)
- return()
-endif()
-
-qt_add_module(WinMain
- STATIC
- NO_SYNC_QT
- NO_MODULE_HEADERS
- DEFINES
- QT_NO_FOREACH
- INCLUDE_DIRECTORIES
- $<TARGET_PROPERTY:Qt::Core,INTERFACE_INCLUDE_DIRECTORIES>
-)
-
-set_property(TARGET WinMain PROPERTY OUTPUT_NAME qtmain)
-
-qt_extend_target(WinMain CONDITION
- SOURCES qtmain_win.cpp
- LIBRARIES shell32
-)
-
-qt_extend_target(WinMain CONDITION MINGW
- DEFINES QT_NEEDS_QMAIN
-)
-# special case end