summaryrefslogtreecommitdiffstats
path: root/src/xml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/xml/CMakeLists.txt')
-rw-r--r--src/xml/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/xml/CMakeLists.txt b/src/xml/CMakeLists.txt
index 982bfb8e54..38b52e3a08 100644
--- a/src/xml/CMakeLists.txt
+++ b/src/xml/CMakeLists.txt
@@ -1,8 +1,6 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from xml.pro.
-
#####################################################################
## Xml Module:
#####################################################################
@@ -13,8 +11,10 @@ qt_internal_add_module(Xml
dom/qdomhelpers.cpp dom/qdomhelpers_p.h
qtxmlglobal.h
DEFINES
+ QT_NO_CONTEXTLESS_CONNECT
QT_NO_FOREACH
QT_NO_USING_NAMESPACE
+ QT_USE_NODISCARD_FILE_OPEN
LIBRARIES
Qt::CorePrivate
PUBLIC_LIBRARIES