summaryrefslogtreecommitdiffstats
path: root/src/xml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/xml/CMakeLists.txt')
-rw-r--r--src/xml/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/xml/CMakeLists.txt b/src/xml/CMakeLists.txt
index 4ddd3f5ceb..38b52e3a08 100644
--- a/src/xml/CMakeLists.txt
+++ b/src/xml/CMakeLists.txt
@@ -1,7 +1,5 @@
# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR GPL-3.0-only WITH Qt-GPL-exception-1.0
-
-# Generated from xml.pro.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## Xml Module:
@@ -13,8 +11,10 @@ qt_internal_add_module(Xml
dom/qdomhelpers.cpp dom/qdomhelpers_p.h
qtxmlglobal.h
DEFINES
+ QT_NO_CONTEXTLESS_CONNECT
QT_NO_FOREACH
QT_NO_USING_NAMESPACE
+ QT_USE_NODISCARD_FILE_OPEN
LIBRARIES
Qt::CorePrivate
PUBLIC_LIBRARIES