summaryrefslogtreecommitdiffstats
path: root/src/xml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/xml/CMakeLists.txt')
-rw-r--r--src/xml/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/src/xml/CMakeLists.txt b/src/xml/CMakeLists.txt
index 7ce740476c..6c7ad3489e 100644
--- a/src/xml/CMakeLists.txt
+++ b/src/xml/CMakeLists.txt
@@ -10,20 +10,26 @@ add_qt_module(Xml
qtxmlglobal.h
sax/qxml.cpp sax/qxml.h sax/qxml_p.h
DEFINES
- QT_NO_USING_NAMESPACE
QT_NO_FOREACH
+ QT_NO_USING_NAMESPACE
LIBRARIES
Qt::CorePrivate
- # PRECOMPILED_HEADER = <EMPTY>
- # _LOADED = "qt_module"
+ PUBLIC_LIBRARIES
+ Qt::Core
)
+#### Keys ignored in scope 1:.:.:xml.pro:<TRUE>:
+# PRECOMPILED_HEADER = <EMPTY>
+# _LOADED = "qt_module"
+
## Scopes:
#####################################################################
-extend_target(Xml CONDITION MSVC AND (TEST_architecture_arch STREQUAL "i386")
+extend_target(Xml CONDITION MSVC AND (TEST_architecture_arch STREQUAL "i386")
LINK_OPTIONS
"/BASE:0x61000000"
)
+add_qt_docs(
+ doc/qtxml.qdocconf
+)
-add_qt_docs(./doc/qtxml.qdocconf)