summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 0bd3b47d92..c03838bee1 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,8 +1,6 @@
# Generated from auto.pro.
-if (NOT APPLE_UIKIT)
- add_subdirectory(corelib)
-endif()
+add_subdirectory(corelib)
if (QT_FEATURE_dbus)
set(run_dbus_tests ON)
if(NOT CMAKE_CROSSCOMPILING AND TARGET Qt::DBus)
@@ -22,9 +20,18 @@ if (QT_FEATURE_dbus)
add_subdirectory(dbus)
endif()
endif()
-if (NOT APPLE_UIKIT AND TARGET Qt::Gui)
+if (TARGET Qt::Gui)
add_subdirectory(gui)
endif()
+
+# special case begin
+# Build only corelib and gui tests when targeting uikit (iOS),
+# because the script can't handle the SUBDIRS assignment well.
+if (APPLE_UIKIT)
+ return()
+endif()
+# special case end
+
if (TARGET Qt::Network AND NOT WINRT)
add_subdirectory(network)
endif()