summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 367832efb6..46dcdcca2b 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -74,7 +74,6 @@ if (NOT WIN32)
expect_pass(test_add_resources_delayed_file)
endif()
expect_pass(test_private_includes)
-expect_pass(test_modules)
expect_pass(test_testlib_definitions)
expect_pass(test_json_plugin_includes)
@@ -92,23 +91,23 @@ execute_process(COMMAND ${CMAKE_COMMAND} -E copy
set(qt_module_includes
Core QObject
- Concurrent QtConcurrentRun
Gui QImage
Widgets QWidget
Network QHostInfo
- OpenGL QGLContext
+ OpenGL QGLBuffer
Sql QSqlError
- Test QSignalSpy
+ Test QTestEventList
Xml QDomDocument
PrintSupport QPrintDialog
)
if (UNIX AND NOT APPLE AND NOT QNXNTO)
list(APPEND qt_module_includes
- DBus QDBusConnection
+ DBus QDBusMessage
)
endif()
test_module_includes(
${qt_module_includes}
)
+expect_pass(test_concurrent_module)