summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_add_resources_binary_generated/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/test_add_resources_binary_generated/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_add_resources_binary_generated/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/tests/auto/cmake/test_add_resources_binary_generated/CMakeLists.txt b/tests/auto/cmake/test_add_resources_binary_generated/CMakeLists.txt
index c7839348a7..df9ef0c3bb 100644
--- a/tests/auto/cmake/test_add_resources_binary_generated/CMakeLists.txt
+++ b/tests/auto/cmake/test_add_resources_binary_generated/CMakeLists.txt
@@ -1,4 +1,7 @@
-cmake_minimum_required(VERSION 3.14)
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
project(test_add_resources_binary_generated)
@@ -18,15 +21,15 @@ qt6_add_resources(test_add_resources_binary_generated resources2 FILES resource2
target_compile_definitions(test_add_resources_binary_generated
PRIVATE
- RESOURCE1_FULL_PATH="${CMAKE_CURRENT_BINARY_DIR}/generated_resources1.rcc")
+ RESOURCE1_FULL_PATH="${CMAKE_CURRENT_BINARY_DIR}/resources1.rcc")
target_compile_definitions(test_add_resources_binary_generated
PRIVATE
RESOURCE2_FULL_PATH="${CMAKE_CURRENT_BINARY_DIR}/resources2_custom.rcc")
-if(NOT TARGET binary_resource_generated_resources1)
+if(NOT TARGET binary_resource_resources1)
message(FATAL_ERROR "Generated resources binary target was not created")
endif()
-if(NOT TARGET binary_resource_generated_resources2)
+if(NOT TARGET binary_resource_resources2)
message(FATAL_ERROR "Generated resources binary target was not created")
endif()