summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_qtmainwin_library/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/test_qtmainwin_library/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_qtmainwin_library/CMakeLists.txt18
1 files changed, 6 insertions, 12 deletions
diff --git a/tests/auto/cmake/test_qtmainwin_library/CMakeLists.txt b/tests/auto/cmake/test_qtmainwin_library/CMakeLists.txt
index 40ccb41da7..b4f3a102e2 100644
--- a/tests/auto/cmake/test_qtmainwin_library/CMakeLists.txt
+++ b/tests/auto/cmake/test_qtmainwin_library/CMakeLists.txt
@@ -1,20 +1,14 @@
-cmake_minimum_required(VERSION 2.8)
+cmake_minimum_required(VERSION 3.14)
project(test_qtmainwin_library)
-find_package(Qt5Core REQUIRED)
+find_package(Qt6Core REQUIRED)
-include_directories(${Qt5Core_INCLUDE_DIRS})
+qt_wrap_cpp(moc_files myobject.h)
-add_definitions(${Qt5Core_DEFINITIONS})
-
-qt5_wrap_cpp(moc_files myobject.h)
-
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
-
-# On non-windows, the WIN32 is harmless, and Qt5Core_QTMAIN_LIBRARIES is empty.
+# On non-windows, the WIN32 is harmless, and Qt6Core_QTMAIN_LIBRARIES is empty.
# We test that it is harmless on those, and test that it builds on Windows.
-# It wouldn't build if WIN32 is used and Qt5Core_QTMAIN_LIBRARIES is empty.
+# It wouldn't build if WIN32 is used and Qt6Core_QTMAIN_LIBRARIES is empty.
add_executable(myobject WIN32 myobject.cpp ${moc_files} )
-target_link_libraries(myobject ${Qt5Core_LIBRARIES} ${Qt5Core_QTMAIN_LIBRARIES})
+target_link_libraries(myobject PRIVATE Qt::Core ${Qt6Core_QTMAIN_LIBRARIES})