summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_static_resources/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/test_static_resources/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_static_resources/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_static_resources/CMakeLists.txt b/tests/auto/cmake/test_static_resources/CMakeLists.txt
new file mode 100644
index 0000000000..e3cab9cf4a
--- /dev/null
+++ b/tests/auto/cmake/test_static_resources/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+
+include(.cmake.conf)
+
+project(TestStaticResources
+ DESCRIPTION "Test of the static resources"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+ VERSION "${QT_REPO_MODULE_VERSION}"
+)
+
+find_package(Qt6 COMPONENTS Core BuildInternals Test CONFIG REQUIRED)
+qt_internal_project_setup()
+
+qt_build_repo_begin()
+
+enable_testing()
+add_subdirectory(mock_static_resources1)
+add_subdirectory(test_init_resources_static_plugin)
+add_subdirectory(test_static_resources_propagation)
+
+qt_build_repo_post_process()
+qt_build_repo_end()