summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/global/qlogging/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/global/qlogging/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/global/qlogging/CMakeLists.txt26
1 files changed, 12 insertions, 14 deletions
diff --git a/tests/auto/corelib/global/qlogging/CMakeLists.txt b/tests/auto/corelib/global/qlogging/CMakeLists.txt
index 7c74656215..ce9235f91e 100644
--- a/tests/auto/corelib/global/qlogging/CMakeLists.txt
+++ b/tests/auto/corelib/global/qlogging/CMakeLists.txt
@@ -1,19 +1,17 @@
-if(NOT WINRT)
- add_qt_executable(qlogging_helper
- NO_INSTALL # special case
- OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
- SOURCES app/main.cpp
- DEFINES QT_MESSAGELOGCONTEXT
- LIBRARIES Qt::Core)
+add_qt_executable(qlogging_helper
+ NO_INSTALL # special case
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+ SOURCES app/main.cpp
+ DEFINES QT_MESSAGELOGCONTEXT
+ LIBRARIES Qt::Core)
- #special case begin
- # Fixes required for the backtrace stack to be correct
- if (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU" AND NOT MINGW)
- target_link_options(qlogging_helper PRIVATE -rdynamic)
- endif()
- set_target_properties(qlogging_helper PROPERTIES CXX_VISIBILITY_PRESET default)
- # special case end
+#special case begin
+# Fixes required for the backtrace stack to be correct
+if (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU" AND NOT MINGW)
+ target_link_options(qlogging_helper PRIVATE -rdynamic)
endif()
+set_target_properties(qlogging_helper PROPERTIES CXX_VISIBILITY_PRESET default)
+# special case end
add_qt_test(tst_qlogging SOURCES tst_qlogging.cpp
DEFINES