summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/global/qlogging/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/global/qlogging/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/global/qlogging/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/auto/corelib/global/qlogging/CMakeLists.txt b/tests/auto/corelib/global/qlogging/CMakeLists.txt
index ce9235f91e..e47f62776d 100644
--- a/tests/auto/corelib/global/qlogging/CMakeLists.txt
+++ b/tests/auto/corelib/global/qlogging/CMakeLists.txt
@@ -1,11 +1,14 @@
-add_qt_executable(qlogging_helper
+# Generated from qlogging.pro.
+# This file is almost completely custom written # special case
+
+qt_add_executable(qlogging_helper
NO_INSTALL # special case
OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
SOURCES app/main.cpp
DEFINES QT_MESSAGELOGCONTEXT
LIBRARIES Qt::Core)
-#special case begin
+# special case begin
# Fixes required for the backtrace stack to be correct
if (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU" AND NOT MINGW)
target_link_options(qlogging_helper PRIVATE -rdynamic)
@@ -13,7 +16,7 @@ endif()
set_target_properties(qlogging_helper PROPERTIES CXX_VISIBILITY_PRESET default)
# special case end
-add_qt_test(tst_qlogging SOURCES tst_qlogging.cpp
+qt_add_test(tst_qlogging SOURCES tst_qlogging.cpp
DEFINES
QT_MESSAGELOGCONTEXT
QT_DISABLE_DEPRECATED_BEFORE=0