summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qbuffer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qbuffer/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qbuffer/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/tests/auto/corelib/io/qbuffer/CMakeLists.txt b/tests/auto/corelib/io/qbuffer/CMakeLists.txt
index 5a374173ef..87022451a0 100644
--- a/tests/auto/corelib/io/qbuffer/CMakeLists.txt
+++ b/tests/auto/corelib/io/qbuffer/CMakeLists.txt
@@ -1,10 +1,17 @@
-# Generated from qbuffer.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qbuffer Test:
#####################################################################
-qt_add_test(tst_qbuffer
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qbuffer LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qbuffer
SOURCES
tst_qbuffer.cpp
)