summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qfileinfo/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qfileinfo/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/auto/corelib/io/qfileinfo/CMakeLists.txt b/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
index 5fdc764e8a..3b997e1bca 100644
--- a/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
+++ b/tests/auto/corelib/io/qfileinfo/CMakeLists.txt
@@ -5,11 +5,18 @@
## tst_qfileinfo Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qfileinfo LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qfileinfo
SOURCES
tst_qfileinfo.cpp
LIBRARIES
Qt::CorePrivate
+ Qt::TestPrivate
)
# Resources:
@@ -48,5 +55,6 @@ qt_internal_extend_target(tst_qfileinfo CONDITION WIN32
)
if (APPLE)
- target_compile_options(tst_qfileinfo PRIVATE -x objective-c++)
+ enable_language(OBJCXX)
+ set_source_files_properties(tst_qfileinfo.cpp PROPERTIES LANGUAGE OBJCXX)
endif()