summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qprocess/testProcessSpacesArgs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qprocess/testProcessSpacesArgs/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qprocess/testProcessSpacesArgs/CMakeLists.txt33
1 files changed, 8 insertions, 25 deletions
diff --git a/tests/auto/corelib/io/qprocess/testProcessSpacesArgs/CMakeLists.txt b/tests/auto/corelib/io/qprocess/testProcessSpacesArgs/CMakeLists.txt
index 8512c7545b..5ea7bf53f4 100644
--- a/tests/auto/corelib/io/qprocess/testProcessSpacesArgs/CMakeLists.txt
+++ b/tests/auto/corelib/io/qprocess/testProcessSpacesArgs/CMakeLists.txt
@@ -1,42 +1,25 @@
-# Generated from nospace.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-#####################################################################
-## nospace Binary:
-#####################################################################
-
-qt_add_executable(nospace
+qt_internal_add_executable(nospace
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/"
+ CORE_LIBRARY None
SOURCES
main.cpp
- DEFINES
- QT_DISABLE_DEPRECATED_BEFORE=0
- PUBLIC_LIBRARIES
- Qt::Gui
)
-# special case begin
-qt_add_executable(onespace
+qt_internal_add_executable(onespace
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/"
+ CORE_LIBRARY None
SOURCES
main.cpp
- DEFINES
- QT_DISABLE_DEPRECATED_BEFORE=0
- PUBLIC_LIBRARIES
- Qt::Gui
)
set_target_properties(onespace PROPERTIES OUTPUT_NAME "one space")
-qt_add_executable(twospaces
+qt_internal_add_executable(twospaces
OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/"
+ CORE_LIBRARY None
SOURCES
main.cpp
- DEFINES
- QT_DISABLE_DEPRECATED_BEFORE=0
- PUBLIC_LIBRARIES
- Qt::Gui
)
set_target_properties(twospaces PROPERTIES OUTPUT_NAME "two space s")
-# special case end
-
-#### Keys ignored in scope 1:.:.:nospace.pro:<TRUE>:
-# OBJECTS_DIR = "$${OBJECTS_DIR}-nospace"