summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qstandardpaths/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qstandardpaths/CMakeLists.txt17
1 files changed, 10 insertions, 7 deletions
diff --git a/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt b/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt
index be03b3e986..90bc0f3b70 100644
--- a/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt
+++ b/tests/auto/corelib/io/qstandardpaths/CMakeLists.txt
@@ -1,26 +1,29 @@
-# Generated from qstandardpaths.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qstandardpaths Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qstandardpaths LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
list(APPEND test_data "tst_qstandardpaths.cpp")
-list(APPEND test_data "qstandardpaths.pro")
-qt_add_test(tst_qstandardpaths
+qt_internal_add_test(tst_qstandardpaths
SOURCES
- ../../../../shared/emulationdetector.h
tst_qstandardpaths.cpp
- INCLUDE_DIRECTORIES
- ../../../../shared
TESTDATA ${test_data}
)
## Scopes:
#####################################################################
-qt_extend_target(tst_qstandardpaths CONDITION boot2qt
+qt_internal_extend_target(tst_qstandardpaths CONDITION boot2qt
DEFINES
SKIP_FINDEXECUTABLE
)