summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qtemporarydir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qtemporarydir/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qtemporarydir/CMakeLists.txt21
1 files changed, 15 insertions, 6 deletions
diff --git a/tests/auto/corelib/io/qtemporarydir/CMakeLists.txt b/tests/auto/corelib/io/qtemporarydir/CMakeLists.txt
index f1c3db54d0..0ddde7d0b3 100644
--- a/tests/auto/corelib/io/qtemporarydir/CMakeLists.txt
+++ b/tests/auto/corelib/io/qtemporarydir/CMakeLists.txt
@@ -1,15 +1,24 @@
-# Generated from qtemporarydir.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qtemporarydir Test:
#####################################################################
-qt_add_test(tst_qtemporarydir
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qtemporarydir LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qtemporarydir
SOURCES
- ../../../../shared/emulationdetector.h
tst_qtemporarydir.cpp
- INCLUDE_DIRECTORIES
- ../../../../shared
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::TestPrivate
)
+
+qt_internal_extend_target(tst_qtemporarydir CONDITION WIN32
+ LIBRARIES
+ shlwapi
+)