summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qurlinternal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qurlinternal/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qurlinternal/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/tests/auto/corelib/io/qurlinternal/CMakeLists.txt b/tests/auto/corelib/io/qurlinternal/CMakeLists.txt
index 80f8e0d128..a5c36b6ed9 100644
--- a/tests/auto/corelib/io/qurlinternal/CMakeLists.txt
+++ b/tests/auto/corelib/io/qurlinternal/CMakeLists.txt
@@ -1,4 +1,11 @@
-# Generated from qurlinternal.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qurlinternal LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
if(NOT QT_FEATURE_private_tests)
return()
@@ -8,13 +15,10 @@ endif()
## tst_qurlinternal Test:
#####################################################################
-qt_add_test(tst_qurlinternal
+qt_internal_add_test(tst_qurlinternal
SOURCES
tst_qurlinternal.cpp
utf8data.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
)
-
-#### Keys ignored in scope 1:.:.:qurlinternal.pro:<TRUE>:
-# _REQUIREMENTS = "qtConfig(private_tests)"