summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qurlquery/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qurlquery/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qurlquery/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/auto/corelib/io/qurlquery/CMakeLists.txt b/tests/auto/corelib/io/qurlquery/CMakeLists.txt
index 80a8ba1a3c..c9f5491416 100644
--- a/tests/auto/corelib/io/qurlquery/CMakeLists.txt
+++ b/tests/auto/corelib/io/qurlquery/CMakeLists.txt
@@ -1,15 +1,20 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from qurlquery.pro.
-
#####################################################################
## tst_qurlquery Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qurlquery LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qurlquery
SOURCES
tst_qurlquery.cpp
LIBRARIES
Qt::CorePrivate
+ Qt::TestPrivate
)