summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/io/qzip/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/io/qzip/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/io/qzip/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/auto/corelib/io/qzip/CMakeLists.txt b/tests/auto/corelib/io/qzip/CMakeLists.txt
new file mode 100644
index 0000000000..df562c5e34
--- /dev/null
+++ b/tests/auto/corelib/io/qzip/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qzip Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qzip LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+# Collect test data
+file(GLOB_RECURSE test_data
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ testdata/*
+)
+
+qt_internal_add_test(tst_qzip
+ SOURCES
+ tst_qzip.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ TESTDATA ${test_data}
+)