summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/ipc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/ipc/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/ipc/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/auto/corelib/ipc/CMakeLists.txt b/tests/auto/corelib/ipc/CMakeLists.txt
new file mode 100644
index 0000000000..751d093788
--- /dev/null
+++ b/tests/auto/corelib/ipc/CMakeLists.txt
@@ -0,0 +1,14 @@
+# Copyright (C) 2022 Intel Corporation.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT ANDROID AND NOT UIKIT)
+ if(QT_FEATURE_sharedmemory OR QT_FEATURE_systemsemaphore)
+ add_subdirectory(qnativeipckey)
+ endif()
+ if(QT_FEATURE_sharedmemory)
+ add_subdirectory(qsharedmemory)
+ endif()
+ if(QT_FEATURE_systemsemaphore)
+ add_subdirectory(qsystemsemaphore)
+ endif()
+endif()