summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/ipc/qsharedmemory/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/ipc/qsharedmemory/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/ipc/qsharedmemory/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/auto/corelib/ipc/qsharedmemory/CMakeLists.txt b/tests/auto/corelib/ipc/qsharedmemory/CMakeLists.txt
new file mode 100644
index 0000000000..e49c8d7828
--- /dev/null
+++ b/tests/auto/corelib/ipc/qsharedmemory/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qsharedmemory LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qsharedmemory
+ SOURCES
+ tst_qsharedmemory.cpp
+ LIBRARIES
+ Qt::CorePrivate
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_qsharedmemory CONDITION LINUX
+ LIBRARIES
+ rt
+)
+add_subdirectory(producerconsumer)
+if(QT_FEATURE_process)
+ add_dependencies(tst_qsharedmemory producerconsumer_helper)
+endif()