summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/kernel/qobject/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/kernel/qobject/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/kernel/qobject/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/auto/corelib/kernel/qobject/CMakeLists.txt b/tests/auto/corelib/kernel/qobject/CMakeLists.txt
new file mode 100644
index 0000000000..46b8e2d238
--- /dev/null
+++ b/tests/auto/corelib/kernel/qobject/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qobject Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qobject LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_qobject
+ SOURCES
+ tst_qobject.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Network
+ Qt::TestPrivate
+)
+
+## Scopes:
+#####################################################################
+add_subdirectory(signalbug)
+add_dependencies(tst_qobject signalbug_helper)