summaryrefslogtreecommitdiffstats
path: root/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt')
-rw-r--r--tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt14
1 files changed, 4 insertions, 10 deletions
diff --git a/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt b/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt
index 366e76d034..c96e6a8825 100644
--- a/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt
+++ b/tests/auto/corelib/kernel/qsharedmemory/CMakeLists.txt
@@ -1,7 +1,6 @@
# Generated from qsharedmemory.pro.
-
-if(QT_FEATURE_sharedmemory)
+if(QT_FEATURE_sharedmemory) # special case
#####################################################################
## tst_qsharedmemory Test:
#####################################################################
@@ -9,13 +8,10 @@ if(QT_FEATURE_sharedmemory)
add_qt_test(tst_qsharedmemory
SOURCES
tst_qsharedmemory.cpp
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
)
-#### Keys ignored in scope 4:.:.:test.pro:<TRUE>:
- # CONFIG = "testcase"
-
## Scopes:
#####################################################################
@@ -23,8 +19,6 @@ if(QT_FEATURE_sharedmemory)
PUBLIC_LIBRARIES
rt
)
-
- if(NOT WINRT)
- add_subdirectory(producerconsumer)
- endif()
+# if(QT_FEATURE_sharedmemory) # special case
+ add_subdirectory(producerconsumer)
endif()